Page 1 of 1

Error Messages

Posted: 2018-08-24, 10:55
by tschlossmacher
Hello, sorry I´m not really good at programming but i get two error messages where i dont really know what to do now.

1. Email Notification isnt working: My Configuration Settings are:
- smtp.web.de
- Port: 587
- Use the TLS/SSL protocol for the SMTP connection: checkmark YES

For example when i create a User, i get the email error: Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\helpers\notification.helper.php on line 513

Can you help me, what i have to do exactly or what to install that it is working with my E-Mail Provider web.de


2. Error Message when I want to edit an User:
Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\helpers\global.helper.php on line 559

Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\helpers\global.helper.php on line 569

Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\helpers\global.helper.php on line 576


I get this message several times one underneath the other.


Sorry, that i disturb you again.

But many thanks in advance for your help again.

Kind regards
Tobias

Re: Error Messages

Posted: 2018-08-26, 15:29
by George
Hi Tobias,
the first problem seems to be one with the connection to your mail server. Is it up and running and is the connection ok?

The global.helper error is weird. I can't reproduce it. But I have created an alternate version that might not throw the error you ar receieving. Try the attached file as an replacement for helpers/global.helper.php. See if that works.
global.helper.zip
(7.14 KiB) Downloaded 14 times
Best regards
George

Re: Error Messages

Posted: 2018-08-28, 15:14
by tschlossmacher
Hi George,

where can i check if the connection is working? Its not an internal Exchangeserver or something. It´s just and email account on web.de

Unfortunately, i still get the error when i edit an user.

Can i send you any logfile or something, where you can search for the error?

And where can i find such a log or errorfile.

Thank you :)

Kind regards

Tobias

Re: Error Messages

Posted: 2018-08-28, 16:28
by George
Hi Tobias,

in your settings you use smtp.web.de but the error says "localhost".
Did you check "Use external SMTP server"?

The other error requires several files to be changed. I will incorporate that in the next release.

Best regards
George