Calender view: "All (by group)" does not return a result

If you need support with TeamCal Pro (installation, configuration, usage) post your request here.
Post Reply
User avatar
Craxx
Junior Boarder
Junior Boarder
Posts: 20
Joined: 2012-02-07, 21:14
Are you a spam bot?: No

Calender view: "All (by group)" does not return a result

Post by Craxx » 2015-09-14, 18:32

Hy George,

in thge calender view, showing group: all, groups don´t work, doesn´t show anything.
Showing all works and showing one group does work also.

There are 19 groups and a lot of people in the calender. At the beginning it works fine, but afer some new entries it doesn´t work anymore.

Please what can i do?

best regards
Craxx ;-)
Attachments
2015-09-14 18_29_05-TeamCal Pro Kalender.png
2015-09-14 18_29_05-TeamCal Pro Kalender.png (48.58 KiB) Viewed 1397 times
2015-09-14 18_27_27-TeamCal Pro Kalender.png
2015-09-14 18_27_27-TeamCal Pro Kalender.png (20.07 KiB) Viewed 1397 times
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 389
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re: Calender view: "All (by group)" does not return a result

Post by George » 2015-09-14, 20:31

Hi Craxx,
can you give me access to your instance? Send me a PM if possible.
Best regards,
George
User avatar
Craxx
Junior Boarder
Junior Boarder
Posts: 20
Joined: 2012-02-07, 21:14
Are you a spam bot?: No

Re: Calender view: "All (by group)" does not return a result

Post by Craxx » 2015-09-22, 18:49

Hy George,

i send you yesterday a PM with the login data.
THX for your help :-D

best regards
Craxx ;-)
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 389
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re: Calender view: "All (by group)" does not return a result

Post by George » 2015-09-22, 20:50

Hi Craxx,
thank you for letting me access your installation.

Root Cause
The reason why the "All (by group)" display shows no result is a simple script timeout. It looks like your maximum execution time (http://php.net/manual/de/info.configura ... ution-time) is set to 60 seconds after which the script is not done yet.

Why is the script not done yet and why does the normal "All" display work?
When you select "All (by group)", the script has additional things to do, e.g. reading and grouping all users by groups. Users that are member of several groups are read mutliple times. It happens to be the case that in your environment the "All" display just finishes within the 60 seconds while the "All (by group)" feature takes longer than that. It times out and shows no result.

What else can you do to lower the execution time of the calendar script?
I noticed that you have "Fast Edit" enabled in your installation. While that is a real cool and useful feature, it really puts a lot of stress on the script. Many POST variables and form objects are created and placed into the calendar table. As the comment on the configuration page says, it is only recommended to use this feature for a small amount of users, like up to 20. You have much more than that. I took the liberty to switch Fast Edit off in your instance and now the "All (by group)" display returns a proper result.
Other users might run into this situation too, so I updated the help page accordingly: https://georgelewe.atlassian.net/wiki/d ... 6/Calendar

What to do if you need/want Fast Edit?
Try to increase the max_execution_time setting in yor php.ini file. Try 120 seconds for example.

Best regards,
George
User avatar
Craxx
Junior Boarder
Junior Boarder
Posts: 20
Joined: 2012-02-07, 21:14
Are you a spam bot?: No

Re: Calender view: "All (by group)" does not return a result

Post by Craxx » 2015-09-24, 11:44

Hy Gerorge,

you are the best !!!!
Thx a lot, now it works...i disabled fast edit.

best regards
Craxx ;-)
Post Reply