Page 1 of 1

db_query(), Line 125 please help

Posted: 2014-03-03, 12:54
by Craxx
Hy George,

i have two problems. Two weeks ago i moved my Teamcal installation from 1un1 to It seem that all is working fine.

1. One problem is in one group. There are 3 People, but only 1 is displayed when showing the calender and not logged in. In other groups there is not such a problem. The users settinghs are equal. Where can i look to display not only one member, but all 3 ?

2. Today i made a update from 11 to version 12. I uploaded the files and made the new entry in database. Now i go to settings and because of Problem 1.) i looked into Berechtigungsschema: Default (rights) and klick anwenden, the i get this errocrmessage in attachement.

In databse i have no viewFastEdit entry in urlaubsplaner_tc_permissions ???

Now i tried with phpmyadmin this entry
INSERT INTO `urlaubsplaner_tc_permissions` ( `scheme` , `permission` , `admin` , `director` , `manager` , `assistant` , `user` , `public` )
'Default', 'viewFastEdit', 0, 0, 0, 0, 0, 0

And now it works. But where was the problem?

And the the problem 1.) does still exist...

now i tried to change the view permissions and now also my problem 1.) is fixed.

So now it seems all is working. Maybe you can give me the reason for this and some advice, how i can check if the teamcal is working correct.

Hope you can help me.

bestr regards

Re: db_query(), Line 125 please help

Posted: 2014-03-04, 21:03
by George
Hi Craxx
indeed a bug that actually ran into myself yesterday.
A bug in permission_model.php. Fixed in 3.6.013
If you want to manually change before release, here is the diff: ... _model.php

Re: db_query(), Line 125 please help

Posted: 2014-03-06, 15:14
by Craxx
Hy George,

thx for your answer :-D
I fixed the bug with your diff ;-)

best reagrds
Craxx ;-)