Blank page at installation

If you need support with TeamCal Pro (installation, configuration, usage) post your request here.
Post Reply
waol
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: 2014-02-13, 14:54
Are you a spam bot?: No

Blank page at installation

Post by waol » 2014-02-14, 12:01

Hi Guys,

I have tried both on a Centos and a Debian linux distribution and can't go forward the installation page.
After I fill it out and click install I have a blank page.

I saw others reporting this issue in the forum but there is no real step by step solution. the closest one is someone saying in his Linux Distro an extra mysql or php package was needed to get it fixed but he doesn't mention which one.

Any help is very welcome.


Thanks,
Salvo
waol
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: 2014-02-13, 14:54
Are you a spam bot?: No

Re: Blank page at installation

Post by waol » 2014-02-15, 12:23

Do you guys have any idea of what might be going on?
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 382
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re: Blank page at installation

Post by George » 2014-02-16, 19:22

Hi waol
when you look at the source code of the blank page, does it reveal anything?
Do you have PHP short tags enabled?
http://stackoverflow.com/questions/2185 ... short-tags
waol
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: 2014-02-13, 14:54
Are you a spam bot?: No

Re: Blank page at installation

Post by waol » 2014-02-17, 15:34

Hi George,

The blank page is just a 500 Internal Error. I don't see anything when I right click and look for the source code but below you can see the output from wireshark that shows the 500 internal server error.

I have 3 php.ini files
root@debian1:~# find / -name php.ini
/var/www/teamcal/php.ini
/etc/php5/apache2/php.ini
/etc/php5/cli/php.ini


and I see short_open_tag is set to on on both
/etc/php5/apache2/php.ini
/etc/php5/cli/php.ini

; This directive determines whether or not PHP will recognize code between
; <? and ?> tags as PHP source which should be processed as such. It's been
; recommended for several years that you not use the short tag "short cut" and
; instead to use the full <?php and ?> tag combination. With the wide spread use
; of XML and use of these tags by other languages, the server can become easily
; confused and end up parsing the wrong code in the wrong context. But because
; this short cut has been a feature for such a long time, it's currently still
; supported for backwards compatibility, but we recommend you don't use them.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/short-open-tag
short_open_tag = On

While the one in the teamcal directory only contains 1 line "register_globals=off"


Is there any debug I can turn on or any log I can look into?



GET /teamcal/ HTTP/1.1
Host: 10.193.20.117
Connection: keep-alive
Cache-Control: no-cache
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Pragma: no-cache
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.91 Safari/537.36
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en-US,en;q=0.8,en-GB;q=0.6,it;q=0.4

HTTP/1.0 500 Internal Server Error
Date: Mon, 17 Feb 2014 03:31:26 GMT
Server: Apache/2.2.22 (Debian)
X-Powered-By: PHP/5.4.4-14+deb7u7
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 20
Connection: close
Content-Type: text/html

....................
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 382
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re: Blank page at installation

Post by George » 2014-02-18, 20:04

Looks all good to me from a configuration point of view. 500 is server related. That I cannot judge from the application.
Can you try to install XAMPP on a Windows box and run it on there. Then you might be able to compare stuff if it works on the Win box.
Post Reply