editprofile: "apply" as normal user deletes all memberships

If you need support with TeamCal Pro (installation, configuration, usage) post your request here.
Post Reply
uweheinrich
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 2013-03-04, 18:45
Are you a spam bot?: No

editprofile: "apply" as normal user deletes all memberships

Post by uweheinrich » 2013-03-04, 19:42

Hi,
thanks a lot for this marvelous piece of software.
I think I found a little bug:
when logged in as a "normal" user, then hitting "apply" deletes all groups of this user.
Or doesn't recreate it after deleting...

Doing the same as administrator leaves the group(s) of the user unchanged.

Thanks for your support.
best regards
Uwe
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 407
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re: editprofile: "apply" as normal user deletes all membersh

Post by George » 2013-03-05, 18:49

Hi Uwe
nice find, however, to be precise, not the user groups were deleted, just the memberships. Duhh.
I am implementing a fix right now. Will be available in the next release 3.5.002
Best regards,
George
uweheinrich
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 2013-03-04, 18:45
Are you a spam bot?: No

Re: editprofile: "apply" as normal user deletes all membersh

Post by uweheinrich » 2013-03-06, 08:52

Good morning George,

thanks for the fast confirmation.
I'm happily waiting for the next release.

regards
Uwe
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 407
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re: editprofile: "apply" as normal user deletes all membersh

Post by George » 2013-03-10, 16:53

3.5.002 released on 2013-03-10
Post Reply