Installation failed

If you need support with TeamCal Pro (installation, configuration, usage) post your request here.
Post Reply
mipli
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2005-07-12, 17:54

Installation failed

Post by mipli » 2011-07-01, 07:40

Hello,
after the installation of tcpro 33008 I get the error message:
Error: A problem was encountered while executing this query:

SELECT value FROM my_tc_user_options WHERE `username`="" AND `option`="language"

Error: Fatal database error!
Does anybody has a solution?
Many thanks and best regards,
Mipli.
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 408
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re:Installation failed

Post by George » 2011-07-05, 18:07

Hi mipli,
when exactly does this error occur? Does the installation go through and you get this message when you try to log in?
Best regards,
George
TeamCal Neo is free for private use but requires licensing for use in a commercial environment:
https://georgelewe.atlassian.net/wiki/s ... eo+License
mipli
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2005-07-12, 17:54

Re:Installation failed

Post by mipli » 2011-07-15, 21:14

Hi George,
the installation go through and what I've posted is the first screen instead of the unlogged calendar view.

I have tried a former version with the same result. But I have a runnning instance 3.3.005 in another db on the same hoster. Could it bem that the problem is related to a wrong db setting?

Many thanks an best regards,
Michael.
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 408
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re:Installation failed

Post by George » 2011-07-16, 18:44

Hi mipli,

did u install with empty data or sample data? You might wanna try with sample data and then delete the users if you dont need em.

Best regards,
George
TeamCal Neo is free for private use but requires licensing for use in a commercial environment:
https://georgelewe.atlassian.net/wiki/s ... eo+License
mipli
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2005-07-12, 17:54

Re:Installation failed

Post by mipli » 2011-07-19, 08:57

Hi George,
I fill out the installation sheet
../tcpro/installation.php

and after submitting the error message appears as described before. This behaviour is independent of using the option sample or empty data.

I have created a new DB, run the setup again and it works.
So there must be a difference in the DB setup I have to search for.

Thx,
Michael.
SnakeEye
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: 2011-08-17, 04:48

Re:Installation failed

Post by SnakeEye » 2011-08-17, 00:57

I get the same error no matter what database file I use. After I submit to install I get:

Code: Select all

Invalid default value for 'last_login'
and if I try to go to the index page I get:

Code: Select all

Error: A problem was encountered while executing this query:

SELECT value FROM my_tc_user_options WHERE `username`="" AND `option`="language"

Error: Fatal database error!
because it won't install the user tables due to the sql errors.
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 408
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re:Installation failed

Post by George » 2011-08-18, 16:15

Can you use phpMyadmin and import the attached sample data. See if it works.

Best regards,
George [file name=sample.zip size=5111]http://www.lewe.com/images/fbfiles/files/sample.zip[/file]
TeamCal Neo is free for private use but requires licensing for use in a commercial environment:
https://georgelewe.atlassian.net/wiki/s ... eo+License
rcharles101
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 2011-09-01, 12:25

Re:Installation failed

Post by rcharles101 » 2011-09-01, 08:31

I have the same problem with snake eye...

I installed and used different database but still I get the same result.

I used your zip file to import the SQL it is still the same...

--------------------------------------

Error

SQL query:

CREATE TABLE `my_tc_users` ( `username` varchar(40) NOT NULL default '', `password` varchar(40) default NULL, `firstname` varchar(80) default NULL, `lastname` varchar(80) default NULL, `title` varchar(80) default NULL, `position` varchar(80) default NULL, `group` varchar(50) default NULL, `phone` varchar(50) default NULL, `mobile` varchar(50) default NULL, `email` varchar(100) default NULL, `notify` tinyint(4) default '0', `notify_group` varchar(50) default NULL, `status` tinyint(4) default '0', `usertype` tinyint(4) default '0', `ut_group` varchar(50) default NULL, `privileges` tinyint(4) NOT NULL default '1', `bad_logins` int(11) default '0', `bad_logins_start` varchar(15) default NULL, `last_pw_change` datetime default NULL, `birthday` date default NULL, `idnumber` varchar(40) default NULL, `last_login` datetime NOT NULL default '', `custom1` varchar(80) NOT NULL default '', `custom2` varchar(80) NOT NULL def[...]

MySQL said: Documentation
#1067 - Invalid default value for 'last_login'

---------------------------

Can you please let me with this, I want to try this system out. Thanks a lot.
mipli
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2005-07-12, 17:54

Re:Installation failed

Post by mipli » 2011-09-01, 13:07

Hi rcharles101.

The create stmt try to create a column "last_login" with type datetime and the constraint NOT NULL. But then it's not possible to set as default value ''.

I would recommend to delete the default value in the stmt or set 01.01.1970.

regards,
Mipli.
rcharles101
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 2011-09-01, 12:25

Re:Installation failed

Post by rcharles101 » 2011-09-01, 15:05

thanks a lot.
Post Reply