Problem Running on Netware 6.5 Apache2 php5.05

If you need support with TeamCal Pro (installation, configuration, usage) post your request here.
Post Reply
AlSchedl
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 2010-06-28, 13:54

Problem Running on Netware 6.5 Apache2 php5.05

Post by AlSchedl » 2010-07-01, 14:41

Hi there,

when trying to log in into TeamCalPro3.03 i get the following php error:
[30-Jun-2010 09:23:58] PHP Fatal error: Call to undefined function crypt() in SYS:/Apache2/htdocs/tcpro/includes/tclogin.class.php on line 301

This only happens in this specific environment running on a Netware 6.5 Server:

Apache/2.0.59 (NETWARE) mod_jk/1.2.21 PHP/5.0.5
Listening on port(s): 443 631 80
Loaded dynamic module util_ldap.c
Loaded dynamic module mod_auth_ldap.c
Loaded dynamic module mod_jk.c
Loaded dynamic module mod_rewrite.c
Loaded dynamic module util_ldap2.c
Loaded dynamic module mod_auth_ldapdn.c
Loaded dynamic module mod_ipp.c
Loaded dynamic module mod_expires.c
Loaded dynamic module mod_headers.c
Loaded dynamic module mod_xsrv.c
Loaded dynamic module sapi_apache2.c


I think some extension containing function crypt() is missing in this - very uncommon and outdated - environment. Everything is fine running TeamCal on Xampp (Windows) or other LAMP-Systems.

Any hints where to look at ? I´d definitely like to install TeamCal in our company which at this point - only offers me this (outdated) environment to get it up and running.:S

Best Regards
Alex Schedlbauer
AlSchedl
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: 2010-06-28, 13:54

Re:Problem Running on Netware 6.5 Apache2 php5.05

Post by AlSchedl » 2010-07-02, 10:03

Hi there,

I was lucky to fix this issue myself.:)

At http://www.gknw.net/phpbb/viewforum.php?f=5 a dedicated NAMP - Supporter offers his own build of php5.2.6 as netware binaries. This version includes the function crypt() that is missing in the php5.0.5 build shipping with netware 6.5 since SP5.

Best regards,

Alex
Post Reply