Installation fails

If you need support with TeamCal Pro (installation, configuration, usage) post your request here.
Post Reply
robertkrz
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2010-03-11, 21:31

Installation fails

Post by robertkrz » 2010-03-11, 16:59

Hi,

I am trying to install TeamCal Pro. I followed install procedure described in doc/install.txt
All steps including sucessful connection to MySQL database works. But after I press "Install" button I get error message:

Error: A problem was encountered while executing this query:
SELECT value FROM `cal_tc_config` WHERE `name` = 'badLogins'
Error: Fatal database error!

It seems that TeamCal tries to run SQL query towards table cal_tc_config ('cal' is my table suffix specified in install window). But when I look to database by phpMyAdmin there are no tables created.

So, I would like to ask:
1. Is install process suppose to create tables in database, or should I create them by hand?
2. If install process should create them, why they were not created?

Thanks in advance for all answers.
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 406
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re:Installation fails

Post by George » 2010-03-11, 21:58

Hi Robert,

yes, the installation routine will create data if you chose to do so on the install page.

Try to import sample.sql manually (phpMyAdmin). You have to edit the fiel first and change the table names according to your prefix.

Best regards,
George
TeamCal Neo is free for private use but requires licensing for use in a commercial environment:
https://georgelewe.atlassian.net/wiki/s ... eo+License
robertkrz
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2010-03-11, 21:31

Re:Installation fails

Post by robertkrz » 2010-03-12, 10:59

Hi George,

Thanks for quick answer.
Before I will run sample.sql I would like to be sure. install.php does not create tables in database? So that is not fault in my installation. Right?
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 406
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re:Installation fails

Post by George » 2010-03-12, 14:10

Hi Robert,

the install routine will check the database information you enter and then import sample.ql or empty.sql according to your choice on the install page.

So, in fact if you import manual you do just the same. Make sure that the install routine created config.tcpro.php with the correct settings for path, url and database.

Best regards,
George
TeamCal Neo is free for private use but requires licensing for use in a commercial environment:
https://georgelewe.atlassian.net/wiki/s ... eo+License
robertkrz
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2010-03-11, 21:31

Re:Installation fails

Post by robertkrz » 2010-03-12, 14:41

Hi George again,

I really appreciate your help with this issue. Thank you!

As you know suffix for tables in sample.sql is hardcoded: exampl: 'my_tc_absence', so I am wonder how suffix for the database entered in install form will affect this installing of tables.
Of course I don't mind to update sample.sql or empty.sql by hand while executing install procedure but it seems that I missed something here.
'config.tcpro.php' was created properly anyhow install script failed. So this part works perfectly.

Sorry for bothering you with detailed question.
User avatar
George
Platinum Boarder
Platinum Boarder
Posts: 406
Joined: 2004-11-29, 21:20
Are you a spam bot?: No
Contact:

Re:Installation fails

Post by George » 2010-03-15, 13:08

Hi Robert,

yes, if you want to use your suffix instead you have to edit the sample.sql file and replace the "my_" with your suffix.

The suffix that TeamCal will be using is set in config.tcpro.php. Once you have imported the tables and records into your database you should be able to use TeamCal.

Best regards,
George
TeamCal Neo is free for private use but requires licensing for use in a commercial environment:
https://georgelewe.atlassian.net/wiki/s ... eo+License
robertkrz
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: 2010-03-11, 21:31

Re:Installation fails

Post by robertkrz » 2010-03-15, 13:25

Thanks a lot George!
I have done this actually already this weekend. Modified empty.sql to fit my suffix, then install tables in database (by the way there were some problems with a Copyright string which contained some characters not accepted by my DB setup) and then TeamCal works fine.
Very nice application and works so far very stable. Very good work!

Thanks a lot for support as well.

BR,
ROBert
Post Reply